Thursday, February 9, 2012

Installing the Android SDK on Ubuntu 11.10

My harddrive failed, forcing me to reinstall my OS. I decided to upgrade to Ubuntu 11.10, so this is basically a rehash of my previous instructions for Ubuntu 11.04.

  1. Make sure that you have the 32bit compatibility libraries installed if you are using 64bit Ubuntu

  2. If you fail to install the 32bit compatibility libraries you will get an 'adb version' error at the end when you run Eclipse. If you are running 64bit Ubuntu, start out by installing the 32bit libraries

    ~$ sudo apt-get install ia32-libs

  3. Install the JDK
  4. This should be a straight forward step

    ~$ sudo apt-get install openjdk-6-jdk

  5. Download and install Eclipse
  6. Find and download an appropriate version of Eclipse. Since my last instructions for 11.04, the version of Eclipse in the Ubuntu repositories has jumped to 3.7. Hooray! Go ahead and install Eclipse

    ~$ sudo apt-get install eclipse

Youtube Channel

Loading...